debug fehler

Enthält archivierte Beiträge von Hotschi's Board zum Download MOD.
Posten ist hier nicht möglich, bitte das Supportforum dafür verwenden!
Gesperrt
Anonymous

debug fehler

Beitrag von Anonymous » Di 03.Dez, 2002 15:50

hallo,

bei mir kommt folgender debug fehler wenn ich auf den
"download-link und in der admin auf "files" klicke.

-------------------------------------
SQL Error : 1054 Unknown column 'sort' in 'order clause'

SELECT id, file_name, klicks, description, free FROM phpbb_downloads ORDER by sort

Line : 262
File : /home/.../admin/admin_dl_files.php
-------------------------------------

jemand ne idee ?

gruß
alecs

Anonymous

Beitrag von Anonymous » Di 03.Dez, 2002 15:52

sorry, bei dem download link kommt
-------------------------------
SQL Error : 1054 Unknown column 'sort' in 'order clause'

SELECT * FROM phpbb_downloads ORDER by sort

Line : 60
File : /home/.../forum/downloads.php
-------------------------------

gruß
alecs

Anonymous

Beitrag von Anonymous » Fr 06.Dez, 2002 14:33

... ist hier jemand....?

Hotschi

Beitrag von Hotschi » Fr 06.Dez, 2002 20:29

jepp, ich bin hier :-) allerdings gerade erst wieder aus dem urlaub zurück....

in deiner datenbank existiert die tabelle "phpbb_downloads" mit den angegebenen spalten, ja?
oder benutzt du ein anderes prefix?

Hotschi

Anonymous

Beitrag von Anonymous » Di 10.Dez, 2002 10:09

nein, genau das steht bei mir "phpbb_downloads"

gruß
alecs

Hotschi

Beitrag von Hotschi » Di 10.Dez, 2002 12:10

gib mal bitte nen link

Anonymous

Beitrag von Anonymous » Mi 11.Dez, 2002 08:19

sorry ...!

FanHits.de

Hotschi

Beitrag von Hotschi » Mi 11.Dez, 2002 09:23

Hallo

Hast du vielleicht mal von einer älteren Version upgedatet und vergessen die Datenbankstruktur zu überarbeiten?
SQL Error : 1054 Unknown column 'sort' in 'order clause'
Daraus geht meines Erachtens nach hervor, dass die Spalte "sort" fehlt.

Sonst poste doch mal einen Screenshot von deinem MysqlAdmin oder ein C&P, dass ich mir mal deine Datenbankstruktur anschauen kann.

CU

Anonymous

Beitrag von Anonymous » Mi 11.Dez, 2002 15:00

Bild

so ?

hab übrigens nichts verändert, nur downgeloaded und installiert.

Hotschi

Beitrag von Hotschi » Mi 11.Dez, 2002 15:13

Also, zunächst mal kann ich keinen Fehler erkennen. Ich empfehle aber grundsätzlich auf die neueste Version upzudaten, weil ich in dieser einige unfeinheiten ausgebaut habe.

date also mal up (denke an das tabellenupdate - dir fehlt jetzt noch eine spalte), vielleicht klapp es ja dann. ansonsten nochmal melden...

CU

Anonymous

Beitrag von Anonymous » Mi 11.Dez, 2002 15:32

sorry, aber genau diese version hab ich installiert

Hotschi

Beitrag von Hotschi » Mi 11.Dez, 2002 16:08

na dann fehlt dir noch eine spalte, aber das wird damit nicht viel zu tun haben...

mehr weiß ich leider auch nicht...

sorry
hotschi

Anonymous

Beitrag von Anonymous » Do 12.Dez, 2002 07:46

vielleicht hat es auch was damit zu tun "wie" ich die tabellen angelegt
habe.
könntest du mir mal deine tabellenstruktur geben ? ich meine die, die
das phpmyadmin exportiert.

Hotschi

Datenbankstruktur

Beitrag von Hotschi » Do 12.Dez, 2002 07:59

Hier die Datenbankstruktur
phpBB_Downloads.SQL hat geschrieben:# phpMyAdmin MySQL-Dump
# version 2.2.0rc4
# http://phpwizard.net/phpMyAdmin/
# http://phpmyadmin.sourceforge.net/ (download page)
#
# Host: localhost
# Erstellungszeit: December 12, 2002, 7:58 am
# Server Version: 3.23.51
# PHP Version: 4.2.1
# Datenbank : `hophpbb`
# --------------------------------------------------------

#
# Tabellenstruktur für Tabelle `phpbb_downloads`
#

CREATE TABLE phpbb_downloads (
id int(11) NOT NULL auto_increment,
description varchar(255) NOT NULL default '',
file_name varchar(255) NOT NULL default '',
klicks int(11) NOT NULL default '0',
free tinyint(1) NOT NULL default '0',
long_desc text NOT NULL,
sort int(11) NOT NULL default '0',
PRIMARY KEY (id)
) TYPE=MyISAM;
Gruß
Hotschi

Anonymous

Beitrag von Anonymous » Do 12.Dez, 2002 15:04

...und wie auf wundersame weise funktioniert es... :D

knall doch einfach die paar zeilen in deine readme, oder als *.sql file,
mit dazupacken !

supi! vielen dank für den tollen support !

gruß
alecs

Hotschi

Beitrag von Hotschi » Do 12.Dez, 2002 15:37

Ja, werde ich machen...

Entweder cích bin blind, oder es lang wirklich an der einen fehlenden Zeile...so oder so, hauptsache das dang läuft ;)

CU
Hotschi

Gesperrt