Knowledge Base Mx 2.0.2

Allgemeiner Support zum phpBB 2 Board und phpBB 2 Modifikationen
Forumsregeln
Auch wenn hier der Support für phpBB 2 weiterhin aufrecht erhalten bleibt, weisen wir darauf hin, dass das phpBB 2 nicht mehr offiziell unterstützt und weiterentwickelt wird!
Antworten
modbo
User
User
Beiträge: 1422
Registriert: Mo 13.Dez, 2004 11:18
Kontaktdaten:

Beitrag von modbo » Fr 29.Apr, 2005 20:24

zu1. Wieso hinnehmen? Muss ja irgendwo ein Fehler sein ...

zu2. Offensichtlich wir zum Einreichen einer KB die kb_post.php und kb_post_body.tpl verwendet.
Hierin befindet sich der Verweis auf $lang['Article_type'] = 'Sprache';

Es existiert das ganze aber auch noch einmal als kb_add... Darin wird auf die $lang['Category'] = 'Kategorie'; verwiesen.
Wofür ist die denn?

//edit: zu2. die kb_add... ist eine Altlast aus der Vorgängerversion :rolleyes: Also nur die lang_kb.php einfach anpassen.

$lang['Article_type'] = 'Typ';


//edit2: Sind ja doch noch einige Klinken in dem Templates, jedenfalls, wenn man ein phpBB Plus besitzt.

Der Navigationslink zum Portal wird im phpBB Plus nicht angezeigt, weil der language Eintrag im Plus $lang['Home'] heisst und nicht $lang['Portal'].
Faher muss man dieses in der kb_header.php anpassen und in der kb_search.php komplett einfügen.

Code: Alles auswählen

#
# -----  [ OPEN ] -----
#
includes/kb_header.php

#
# -----  [ FIND ] -----
#
'L_PORTAL' => '<a href="'.append_sid("portal.$phpEx").'" class="genmed">'.$lang['Portal'].'</a>',

#
# -----  [ REPLACE, WITH ] -----
#
'L_PORTAL' => '<a href="'.append_sid("portal.$phpEx").'" class="genmed">'.$lang['Home'].'</a>',


#
# -----  [ OPEN ] -----
#
kb_search.php

#
# -----  [ FIND ] -----
#
'L_SEARCH_KEYWORDS' => $lang['Search_keywords'],

#
# -----  [ BEFORE, ADD ] -----
#
'L_PORTAL' => '<a href="'.append_sid("portal.$phpEx").'" class="genmed">'.$lang['Home'].'</a>',
In der Quick KB Navigation steht zur Auswahl GO, dahinter nochmal GO zu Absenden.
Das erste GO habe ich ersetzt durch "Übersicht"

Code: Alles auswählen

#
# ----- [ OPEN ] -----
#
kb_footer.php

#
# ----- [ FIND ] -----
#
'L_QUICK_NAV' => $lang['Quick_nav'],

#
# ----- [ AFTER, ADD ] -----
#
'L_QUICK_CAT' => $lang['Quick_cat'],

#
# ----- [ OPEN ] -----
#
kb_footer.tpl

#
# ----- [ FIND ] -----
#
{L_QUICK_JUMP}

#
# ----- [ REPLACE, WITH ] -----
#
{L_QUICK_CAT}

#
# ----- [ OPEN ] -----
#
language/lang_german/lang_kb.php

#
# ----- [ FIND ] -----
#
$lang['Quick_nav'] = 'Quick KB Navigation';

#
# ----- [ AFTER, ADD ] -----
#
$lang['Quick_cat'] = 'Übersicht';
Zuletzt geändert von modbo am Mi 04.Mai, 2005 21:02, insgesamt 6-mal geändert.

Benutzeravatar
oxpus
Administrator
Administrator
Beiträge: 29116
Registriert: Mo 27.Jan, 2003 22:13
Wohnort: Bad Wildungen
Kontaktdaten:

Beitrag von oxpus » Fr 29.Apr, 2005 23:25

Hast Du schon meinen Fix installiert?
Karsten Ude
-={ Das Mädchen für alles }=-
Kein Support per ICQ, Email oder PN! Unaufgeforderte Nachrichten werden ignoriert!
No support per ICQ, Email or PM. Each unasked message will be ignored!

Benutzeravatar
Snoopy
User
User
Beiträge: 1082
Registriert: So 26.Sep, 2004 19:23
Wohnort: Hannover
Kontaktdaten:

Beitrag von Snoopy » Fr 29.Apr, 2005 23:32

Ja hab ich!

Ist seltsam meine Spiele gehen auch nicht mehr! Hab ich vielleicht irgend was falsch gemacht?

Benutzeravatar
oxpus
Administrator
Administrator
Beiträge: 29116
Registriert: Mo 27.Jan, 2003 22:13
Wohnort: Bad Wildungen
Kontaktdaten:

Beitrag von oxpus » Sa 30.Apr, 2005 08:50

Was hast Du denn um Gottes Willen alles umgebaut?
Karsten Ude
-={ Das Mädchen für alles }=-
Kein Support per ICQ, Email oder PN! Unaufgeforderte Nachrichten werden ignoriert!
No support per ICQ, Email or PM. Each unasked message will be ignored!

Benutzeravatar
Snoopy
User
User
Beiträge: 1082
Registriert: So 26.Sep, 2004 19:23
Wohnort: Hannover
Kontaktdaten:

Beitrag von Snoopy » Sa 30.Apr, 2005 09:30

Wie meinst du das? Ist es vielleicht besser wenn ich den noch mal rausnehme?
Ich hab gesehen in der install.txt. steht eine andere Version(KB MOD 2.0.1(abc...)), ich hab den nämlich nicht von hier :!:

Benutzeravatar
oxpus
Administrator
Administrator
Beiträge: 29116
Registriert: Mo 27.Jan, 2003 22:13
Wohnort: Bad Wildungen
Kontaktdaten:

Beitrag von oxpus » Sa 30.Apr, 2005 13:49

Also mein Fix ist für die KB 2.0.2. Ob in der KB 2.0.1(a-e) alles so auffindbar ist...
Karsten Ude
-={ Das Mädchen für alles }=-
Kein Support per ICQ, Email oder PN! Unaufgeforderte Nachrichten werden ignoriert!
No support per ICQ, Email or PM. Each unasked message will be ignored!

Benutzeravatar
Snoopy
User
User
Beiträge: 1082
Registriert: So 26.Sep, 2004 19:23
Wohnort: Hannover
Kontaktdaten:

Beitrag von Snoopy » Sa 30.Apr, 2005 16:28

Ups und was mach ich nun?

Ich kann die von hier nicht downloaden, der Traffic reicht nicht aus! Uns was mach ich nun?

Bei den Fehlermeldungen hat es mir aber geholfen!

Benutzeravatar
oxpus
Administrator
Administrator
Beiträge: 29116
Registriert: Mo 27.Jan, 2003 22:13
Wohnort: Bad Wildungen
Kontaktdaten:

Beitrag von oxpus » Sa 30.Apr, 2005 17:09

Folge dem Link zum Autor. Von dort kannst Du downloaden. Oder warte bis morgen, dann geht es auch von hier wieder :D
Karsten Ude
-={ Das Mädchen für alles }=-
Kein Support per ICQ, Email oder PN! Unaufgeforderte Nachrichten werden ignoriert!
No support per ICQ, Email or PM. Each unasked message will be ignored!

Benutzeravatar
Snoopy
User
User
Beiträge: 1082
Registriert: So 26.Sep, 2004 19:23
Wohnort: Hannover
Kontaktdaten:

Beitrag von Snoopy » Sa 30.Apr, 2005 17:31

Ich habe den Link gefolgt und von da hab ich den auch! Bin ich der Meinung! und da steht auch im install.txt Version KB MOD 2.0.1(abc...)

Benutzeravatar
oxpus
Administrator
Administrator
Beiträge: 29116
Registriert: Mo 27.Jan, 2003 22:13
Wohnort: Bad Wildungen
Kontaktdaten:

Beitrag von oxpus » Sa 30.Apr, 2005 19:13

Karsten Ude
-={ Das Mädchen für alles }=-
Kein Support per ICQ, Email oder PN! Unaufgeforderte Nachrichten werden ignoriert!
No support per ICQ, Email or PM. Each unasked message will be ignored!

Benutzeravatar
Snoopy
User
User
Beiträge: 1082
Registriert: So 26.Sep, 2004 19:23
Wohnort: Hannover
Kontaktdaten:

Beitrag von Snoopy » Mo 02.Mai, 2005 15:04

Hallo!

Ich hab die KB nun von hier runtergeladen und auch eingebaut.


Wenn ich im ACP eine Kategorie erstellen springt er auf den Board index, aber die linke Navi vom ACP bleibt.

Was soll ich nun machen?

Die PN kommt einigermassen richtig an. Nur wenn ich auf Emailbenachrichtigung gehe kommt das

Code: Alles auswählen

EDIT:Warning: reset(): Passed variable is not an array or object in /usr/export/www/vhosts/funnetwork/hosting/snoopytraum/includes/emailer.php on line 145

Warning: Variable passed to each() is not an array or object in /usr/export/www/vhosts/funnetwork/hosting/snoopytraum/includes/emailer.php on line 146

Warning: reset(): Passed variable is not an array or object in /usr/export/www/vhosts/funnetwork/hosting/snoopytraum/includes/emailer.php on line 154

Warning: Variable passed to each() is not an array or object in /usr/export/www/vhosts/funnetwork/hosting/snoopytraum/includes/emailer.php on line 155

Habe deinen Fix noch nicht gemacht, soll ich es damit erstmal probieren???
Zuletzt geändert von Snoopy am Mo 02.Mai, 2005 16:02, insgesamt 3-mal geändert.

Benutzeravatar
oxpus
Administrator
Administrator
Beiträge: 29116
Registriert: Mo 27.Jan, 2003 22:13
Wohnort: Bad Wildungen
Kontaktdaten:

Beitrag von oxpus » Mo 02.Mai, 2005 23:41

Ja, der behebt einige Fehler. Eigentlich alle mir bekannten.
Karsten Ude
-={ Das Mädchen für alles }=-
Kein Support per ICQ, Email oder PN! Unaufgeforderte Nachrichten werden ignoriert!
No support per ICQ, Email or PM. Each unasked message will be ignored!

Benutzeravatar
Snoopy
User
User
Beiträge: 1082
Registriert: So 26.Sep, 2004 19:23
Wohnort: Hannover
Kontaktdaten:

Beitrag von Snoopy » Di 03.Mai, 2005 00:22

Ok, die Fehlermeldung ist weg, ich kann aber keine weiteren Katagorien erstellen.

Ich bin die Anleitung rauf und runter gegangen, konnte aber nichts feststellen.

Stört da vielleicht ein anderer Mod?

modbo
User
User
Beiträge: 1422
Registriert: Mo 13.Dez, 2004 11:18
Kontaktdaten:

Beitrag von modbo » Di 03.Mai, 2005 07:11

>ich kann aber keine weiteren Katagorien erstellen.
Was passiert denn anstelle?

Benutzeravatar
oxpus
Administrator
Administrator
Beiträge: 29116
Registriert: Mo 27.Jan, 2003 22:13
Wohnort: Bad Wildungen
Kontaktdaten:

Beitrag von oxpus » Di 03.Mai, 2005 07:16

In der KB wird wohl kaum ein anderer Mod installiert sein.
Was passiert denn, wenn Du eine neue Kat. anlegen willst?
Karsten Ude
-={ Das Mädchen für alles }=-
Kein Support per ICQ, Email oder PN! Unaufgeforderte Nachrichten werden ignoriert!
No support per ICQ, Email or PM. Each unasked message will be ignored!

Benutzeravatar
Snoopy
User
User
Beiträge: 1082
Registriert: So 26.Sep, 2004 19:23
Wohnort: Hannover
Kontaktdaten:

Beitrag von Snoopy » Di 03.Mai, 2005 08:10

Sofern ich auf erstellen gehe, springt er auf den Foren index. Aber Navi aus dem ACP auf der Linken Seite ist noch da!

Ich hab keine Ahnung warum das so ist!

Benutzeravatar
oxpus
Administrator
Administrator
Beiträge: 29116
Registriert: Mo 27.Jan, 2003 22:13
Wohnort: Bad Wildungen
Kontaktdaten:

Beitrag von oxpus » Di 03.Mai, 2005 08:55

Genau das sollte ja durch mein Fix behoben werden.
Häng doch mal die admin_kb_cat.php und admin_kb_types.php hier an.

Entweder habe ich das wirklich im Fix vergessen oder es ist falsch eingebaut.
Karsten Ude
-={ Das Mädchen für alles }=-
Kein Support per ICQ, Email oder PN! Unaufgeforderte Nachrichten werden ignoriert!
No support per ICQ, Email or PM. Each unasked message will be ignored!

Benutzeravatar
Snoopy
User
User
Beiträge: 1082
Registriert: So 26.Sep, 2004 19:23
Wohnort: Hannover
Kontaktdaten:

Beitrag von Snoopy » Di 03.Mai, 2005 09:00

Hier die beiden Datein

[ Attachment gelöscht am Di 03.Mai, 2005 19:00 von oxpus ]

Benutzeravatar
oxpus
Administrator
Administrator
Beiträge: 29116
Registriert: Mo 27.Jan, 2003 22:13
Wohnort: Bad Wildungen
Kontaktdaten:

Beitrag von oxpus » Di 03.Mai, 2005 17:59

Ja, waren die falschen Dateien. Sorry.
Hier der Part des Fixes, der Dein Problem behebt:

Code: Alles auswählen

#
#-----[ OPEN ]-----
#
templates/subSilver/admin/kb_cat_admin_body.tpl

#
#-----[ FIND ]-----
#
<form action="{S_ACTION}" method="GET">

#
#-----[ REPLCE WITH ]-----
#
<form action="{S_ACTION}" method="post">

#
#-----[ OPEN ]-----
#
templates/subSilver/admin/kb_type_body.tpl

#
#-----[ FIND ]-----
#
<form action="{S_ACTION}" method="GET">

#
#-----[ REPLCE WITH ]-----
#
<form action="{S_ACTION}" method="post">
Karsten Ude
-={ Das Mädchen für alles }=-
Kein Support per ICQ, Email oder PN! Unaufgeforderte Nachrichten werden ignoriert!
No support per ICQ, Email or PM. Each unasked message will be ignored!

Benutzeravatar
Snoopy
User
User
Beiträge: 1082
Registriert: So 26.Sep, 2004 19:23
Wohnort: Hannover
Kontaktdaten:

Beitrag von Snoopy » Di 03.Mai, 2005 18:23

Super! Danke!

Es funktioniert!!!!


EDIT:

Hab da doch noch mal ne Frage.

Wenn ich die KB verlinken möchte, dann muss das doch so:
http:www.meinedomain.de/kb.php
ausehen, oder?
Aber wenn ich auf dann auf den Link gehe bekomme ich folgendes:

Code: Alles auswählen

SecureSSI: Das Script (/usr/export/www/vhosts/funnetwork/hosting/snoopytraum/kb.php) hat versucht ausserhalb von ihrem Userverzeichniss auf die Datei /usr/export/www/vhosts/funnetwork/hosting/snoopytraum/kb.php zuzugreifen.
Dies ist nicht erlaubt!

Warning: Unknown(): Sicherheitsverletzung: in Unknown on line 0

Warning: Unknown(/usr/export/www/vhosts/funnetwork/hosting/snoopytraum/kb.php): failed to open stream: Operation not permitted in Unknown on line 0

Warning: (null)(): Failed opening '/usr/export/www/vhosts/funnetwork/hosting/snoopytraum/kb.php' for inclusion (include_path='.:') in Unknown on line 0
Leider weiss ich nicht warum!?
Zuletzt geändert von Snoopy am Di 03.Mai, 2005 23:25, insgesamt 1-mal geändert.

modbo
User
User
Beiträge: 1422
Registriert: Mo 13.Dez, 2004 11:18
Kontaktdaten:

Beitrag von modbo » Mi 04.Mai, 2005 00:10

Wo ist denn das Problem? Funktioniert doch :rolleyes:

http://snoopytraum.sn.funpic.de/kb.php

Benutzeravatar
Snoopy
User
User
Beiträge: 1082
Registriert: So 26.Sep, 2004 19:23
Wohnort: Hannover
Kontaktdaten:

Beitrag von Snoopy » Mi 04.Mai, 2005 10:14

hm....Heute Nacht ging es nicht!

helluvaguy
User
User
Beiträge: 132
Registriert: Di 06.Apr, 2004 19:22

Beitrag von helluvaguy » Mi 04.Mai, 2005 10:58

Wie es scheint, habt ihr hier ja weit mehr "Insight" in diesen Mod als der Autor selbst. Ich habe Oxpus Fix angewandt und nun funktioniert alles so wie ich es gerne hätte, nur noch ein Problem ist da.

Wenn ein Beitrag editiert wird, steigt die Azahl der Beiträge in einer Kategorie. Habt ihr ne Idee, wie das zu unterbinden ist. Ich würde ja mal so theoretisieren, dass bei einer Übergabe nach einem Edit die Artikelanzahl genauso erhöht wird, als wenn der Beitrag zum ersten Mal erstellt werden würde. Ich weiß aber nicht so wirklich, wo ich danach suchen sollte.

Benutzeravatar
Snoopy
User
User
Beiträge: 1082
Registriert: So 26.Sep, 2004 19:23
Wohnort: Hannover
Kontaktdaten:

Beitrag von Snoopy » Mi 04.Mai, 2005 11:34

Hab das mal ausprobiert, bei mir ist das gleiche wie bei helluvaguy!

helluvaguy
User
User
Beiträge: 132
Registriert: Di 06.Apr, 2004 19:22

Beitrag von helluvaguy » Mi 04.Mai, 2005 11:48

Mir ist nochetwas aufgefallen:
Ein User hat einen Artikel gepostet.
In meiner PN Inbox steht eine Neue PN 'Knowledge Base - Neuer Artikel!' Klicke ich ihn an, um die PN zu lesen, werde ich einfach wieder in die Inbox geleitet.

Also habe ich versucht über das ACP die PN zu lesen, stellte jedoch fest dass es sie nicht zu geben scheint, was sich bei einem Blick in die DB bestätigte. (in phpbb_privmsgs ist zwar die Überschift vorhanden, doch der Text fehlt in phpbb_prvmsgs_text)

Eine Email ist an den Admin auch nicht rausgegangen.

Antworten